PhpMyNewsLetter 2.0

Support et annonces PhpMyNewsLetter.

Vous n'êtes pas identifié(e).

Annonce

Pour me permettre de mieux vous aider au mieux, merci d'être le plus précis possible en donnant :
- la version de phpmynewsletter utilisée
- votre hébergement : personnel, dédié, mutualisé
- votre hébergeur (OVH, free, Infomaniak, 1and1,...)
- votre OS : linux, windows
- version de PHP (5.3, 5.6, 7.0, hhvm...)
Toutes les réponses à mes questions qui sont sans retour de votre part seront considérées comme résolues !

#1 Support général » [Mail Tester] >> changement d'identifiant à chaque envoi ? » 07-02-2019 08:51:48

realdju
Réponses : 1

Cher Arnaud j'espère que tu vas bien.

Depuis plusieurs mois j'envoie à nouveau mes newsletter avec grand succès et je te remercie toujours pour ton fantastique programme dont la nouvelle version est vraiment hyper light et très agréable.

1) Je t'écris par rapport à Mail Tester, je me trompe peut-être mais il semblerait que nous ne pouvons plus utiliser l'identifiant inscrit dans les paramètres d'envoi mais on doit aller sur MailTester, modifier l'identifiant avec celui proposé par MailTester, puis envoyer la news en PREVIEW pour ensuite la vérifier sur MailTester. Il me semble qu'avant ben on envoyait toujours sur le même identifiant, cela aurait changé il y a environ 3 semaines chez MailTester. Qu'en est-il ? Je sais pas si je suis clair avant on faisait genre https://www.mail-tester.com/identifiant-options-envoi et maintenant l'identifiant est imposé par MailTester depuis leur page d'accueil).

2) Par la même occasion, je voulais te demander si la nouvelle version s'auto-upgradait toute seule ? Il semblerait qu'à présent il y a un traitement des bounces reçus par le mél d'envoi et leur traitement (ainsi que d'autres petites choses) ?

Je te remercie pour l'attention que tu porteras à tes réponses et te souhaite une excellente année.

Julien.

#2 Re : Support général » Liens Newsletters + LaPoste.net » 31-07-2018 15:28:34

Hello Hello,

- Pojnt 4 : Super ton captureur d'écran, voici le shoot pour donner une idée : https://ibb.co/hnvJrc

- Point 3 : voici le type de message que j'obtiens dans le corps du bounce : "@EMAIL connect to smtpz4.laposte.net[194.117.213.1]:25: Connection timed out". Côté interface, j'ai 3 bounces de 3 messageries différentes qui disent : "SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/wiki/Troubleshooting" je sais pas quoi en faire lol (à priori toujours rien).

- Point 2 : ok wink

- Point 1 : Comment puis-je savoir ou dans quelle table dois-je regarder le fameux 1er envoi du dernier (que j'ai de mémoire à peu près, puisqu'après j'ai poursuivi l'envoi) ?

J'en profite pour rajouter une couche >> c'est quoi toutes ces balises quand je compose ma newsletter ?? Est-ce que cela veut dire que toutes mes balises déconnent (et ici à priori elles sont en trop au début à priori ??)

https://ibb.co/dZOq6c

Merci, @ te lire Arnaud wink

#3 Support général » Liens Newsletters + LaPoste.net » 31-07-2018 15:28:34

realdju
Réponses : 5

Coucou Arnaud,

Un peu comme toi je simplifie mes sites, et vraiment tout le monde s'y retrouve : quelle jolie version et quelle simplicité pour la 2.0.5 c'est très agréable !!

Je suis content que tu aies relevé pour la couleur, typiquement, je pensais à un rond de couleur dans la barre du haut, et quand tu cliques dessus, un peu comme les sticky notes de Windows tu choisisses entre le bleu, le vert, le jaune etc wink

Bon bon sinon, je reviens pour feedbacker (et en savoir plus tiens) sur 3 points :

1. Pour ma 1ère newsletter, l'envoi s'est arrêté au 1/3 des abonnés (lors d'un cron de mémoire), du coup j'ai perdu des sous lol. Sur la page d'accueil c'était marqué "en cours d'envoi". Y a-t-il des logs à te transmettre ?

2. Du coup certaines personnes me quémandaient la newsletter de la semaine (cool de constater cela du coup c'est une bonne expérience aussi), mais du coup ça m'a rappelé ma demande initiale : un lien transmissible pour chaque newsletter. Du coup j'ai poursuivi l'envoi depuis les archives pour tt le monde (mieux que rien tongue ). A l'époque tu m'avais répondu que certains webmasters ne désiraient pas de "faille" éventuelle ou que les gens se transmettent le lien pour des newsletters privées, et à cela j'avais proposé que ce soit une fois de plus une option, et que chacun serait content ainsi lol Perso cela permet de mettre sur les réseaux sociaux, c'est tout le but d'une newsletter "classique". La plupart du temps, nous écrivons des newsletters qui demandent à être connues et répandues hihi !! angel

3. J'ai eu 10 retours "bounce" laposte.net sur mon email paramétré dans l'interface mais sur l'interface même je n'ai que 3 retours bounces. Peux-tu me guider sur la marche à suivre ou ce qu'il y a à comprendre ? D'ailleurs je remarque que ces 3 bounces l'ont été pour la 1ère newsletter mais pas la 2ème. J'ai ajouté le DKIM pour la 2ème. Pour le moment, vu le faible nombre, je pense ne rien faire et voir ce que cela donne avec les prochaines. Si tu as des infos je suis preneur.

4. Du coup en écrivant tout cela, d'autres choses me viennent : pas grand chose, mais comme je t'ai dit, j'ai refait mon site, du coup j'ai mis comme toi un logo pour l'accueil (type maison) et c'est tout : je pense que tu peux supprimer "accueil" c'est assez explicite si c'est un peu plus gros. J'ai fait de même pour "Contact" avec une enveloppe à l'heure où le responsive exige des optimisations "menu". Pour le "I" de informations ça pourrait se suffir je pense. Des broutilles hein... wink

@ te lire, et je suis ravi de cette version merci Arnaud pour ton bien joli travail  cool

#4 Support général » [Résolu] Google Fonts dans <style> » 28-03-2018 16:11:14

realdju
Réponses : 1

Salut Arnaud,

J'espère que ça va bien, j'envoie à l'instant ma 1ère news via 2.0.5 et suite aux corrections avec l'identification DKIM etc.

A cette occasion, j'ai galéré dans le header qui disparaissait et mes googles font n'étaient plus prises en compte.

Au bout d'1 h de réflexion blonde, j'ai trouvé ce bout de code pour déplacer ces fonts depuis le <style> et ça fonctionne nickel of course :

<style>
@import url('https://fonts.googleapis.com/css?family=Oswald');
</style>

Pour le reste, je suggèrerais que le bandeau du haut où tu as mis tous les accès "Accueil / Statistiques globales / etc" puisse être de couleur différente, un paramètre que chacun pourrait définir à sa convenance. En fait ça se confond avec le gris clair du navigateur et du coup on dirait que ça fait partie du navigateur, souvent, je dois faire un effort pour retrouver le bon lien.

Ceci est un détail rapport à tout ton boulot mais bon, c'est un feedback quand même lol.

Bon ben si j'ai des soucis je reviendrai poster. Tu peux mettre "résolu" c'était juste une petite contribution/feedback wink

Merci pour ton aide à priori ça semble rouler, à nouveau en cron (afin d'éviter tte coupure et ressource web)  big_smile

#5 Re : script upgrade.php » [Résolu] Pb Installation avec le upgrade » 26-03-2018 06:09:09

Vi' vi' merci je confirme que le chemin physique était présent sur le 2.0.4 et faisait bugger sur la 2.0.5 il suffisait de mettre le nom du répertoire tout simplement, râh le blond !! Merci Arnaud, j'en ai profité pour compléter les onglets DKIM et retour BOUNCE, ce dernier n'ayant pas été repris dans l'upgrade.

Tout va bien, je ferai un test cette semaine, si tu me vois pas dans les parages, c'est que ça roule lol.

Merci encore pour ton soutien  lol

#6 Re : script upgrade.php » [Résolu] Pb Installation avec le upgrade » 26-03-2018 06:09:09

Bonsoir Arnaud,

Je m'excuse de ne pas t'avoir répondu plus tôt, je ne reçois toujours pas les réponses automatiques lorsque tu réponds, et avant d'être occupé à (essayer d') écrire ma nouvelle newsletter ce soir, je ne pensais plus que mon script buggait snif. Alors oui je suis en mutualisé chez O2Switch et jusqu'à présent mon environnement était en dédié/prod et fonctionnait très bien. J'ai en effet modifié le NDD mais toujours le même résultat. En relançant le "upgrade" il me dit que tout est ok, mais toujours pas de possibilité d'accéder au corps de la news (que je vois apparaitre un fragment de seconde).

Bref, puisque j'étais en galère de temps, j'ai décidé d'installer la v5 sur un nouveaux rép/bdd et là contre toute attente, exactement le même bug pour moi, avec néanmoins une installation réussie d'après le soft, mais au moment d'écrire le message, le corps se fait la malle (exactement comme le screen précédemment envoyé). J'ai essayé de mettre en mutualisé, modifié le ndd dans la gestion d'envoi. Il indique néanmoins une erreur en rouge lorsque j'essaie de composer une news et d'enregistrer le message.

Bref >> j'ai remis le backup automatiquement réalisé par ton script (Arnaud soit loué) et j'ai finalement réussi à retrouver mon ancienne version qui fonctionne (hormis la bdd qui indiquait une erreur, toujours sur la table "archives". Faut dire que sur cette pauvre table archives, j'ai parfois supprimer sans préavis des lignes entières, peut-être le bug vient-il de là ?? Certaines tâches cron me foutaient la pétoche si elles s'envoyaient en double et ne s'étaient pas déclencher d'elles-même, ce genre de cas).

Bref, je ne vois que ça - à mon niveau - qui pourrait en effet provoquer des bugs lors de l'upgrade. Mais ça n'expliquerait pas qu'une nouvelle install propre suscite le même bug grrrr hmm

Que puis-je faire d'après toi ?

Merci pour ton aide, et bravo pour le backup sans lequel je n'aurais pu envoyer ma news ce soir !!  big_smile

#7 script upgrade.php » [Résolu] Pb Installation avec le upgrade » 26-03-2018 06:09:09

realdju
Réponses : 6

Salut Arnaud et bravo pour la maj smile

A l'installation les différentes étapes ont toutes été validées, sauf parfois des 503, avec un refresh ça a été.

Par contre, vers la fin j'ai eu ce pb :

" Mise à jour / update table pmn204_archives en erreur / failed !
ALTER TABLE `pmn204_archives` ADD `sender_email` VARCHAR(255) NOT NULL, ADD `draft` LONGTEXT NOT NULL, ADD `preheader` TEXT NOT NULL, CHANGE `message` `message` LONGTEXT NOT NULL, CHANGE `list_id` `list_id` INT(4) NOT NULL DEFAULT '0', CHANGE `subject` `subject` TEXT CHARACTER SET utf8mb4 COLLATE utf8mb4_general_ci NOT NULL, ADD KEY `sender_email` (`sender_email`); "

Lorsque je me log l'interface apparait correctement, lorsque je commence à composer une news depuis un modèle existant ou en classique le textarea du corps du message n'apparait pas par contre (vf capture).

Php_My_News_Letter_Administration_Mozilla_Firefox.jpg

Merci pour ton aide, et bonne soirée  tongue

#8 Re : Support général » [Résolu] Pb Yahoo + Cron » 09-12-2017 11:03:22

Re Arnaud,

Tu n'as pas eu le temps de répondre, mais du coup j'en ai profité pour faire quelquechose : comme tu le sais, j'avais un taux de retour "spam" de 15% sur ma liste Yahoo, alors et bien, je me suis pas pris la tête, j'ai compris que les retours de ces adresses mails spécifiques étaient des spams, alors je les ai purement supprimées et réintégrées les autres à ma liste principale.

De fait, mon envoi s'est bien passé : aucun retour 554 cette fois-ci, le mal éradiqué à la racine. Bon j'ai peut-être fait une bêtise mais je pense pas car ce n'était toujours que 15% de ma liste Yahoo, soit seulement 2,4% de ma liste principale, ce qui veut bien dire que mon adresse d'envoi n'était pas au rebus, puisque 85% passait.

Puisque cela représentait une fraction négligeable de ma newsletter, je n'ai pas souhaité m'emboucaner plus avec des considérations trop complexes.

Je reviendrai poster si le pb se reproduit, mais ça m'étonnerait.

Merci pour ton assistance néanmoins, j'espère que ce retour utilisateur servira à d'autres tongue

Cela reste étrange tout de même que les retours bounce aient eu lieu soudainement du jour au lendemain, peut-être de vieilles adresses récupérées tout au début il y a 5 ans et qui sont devenues obsolètes : bref, on verra bien, ça a l'air ok à présent  angel

#9 Re : Support général » [Résolu] Pb Yahoo + Cron » 09-12-2017 11:03:22

Coucou Arnaud,

Merci d'être présent smile

Alors, MXToolBox indique tous les voyants au vert pour le blacklist check et SenderScore me donne 4 datas dont la moyenne est de 88,5%.

J'ai aussi checké le graph de la liste Yahoo, qui donne aujourd'hui 15% d'ouvertures (à ce sujet merci pour tes moyennes qui me situent c'est super).

Voilou, à te lire...

#10 Re : Support général » [Résolu] Pb Yahoo + Cron » 09-12-2017 11:03:22

Hello Arnaud,

Merci pour ta réponse.

Vu que j'étais un peu à la bourre après cette réponse, et que je suis resté sur l'idée qu'avoir 10% de bounces n'était pas normal, j'ai renvoyé la même newsletter à la liste Yahoo depuis mon serveur car j'avais peur de pas bien paramétrer les DKIM etc. Alors j'ai cependant modifié le nd d'envoi à 1 à la fois (au lieu de 3 par défaut je crois), et aujourd'hui, et bien pas de retours bounces comme j'ai eu pendant 2 semaines. Par ailleurs, 10% d'ouverture seulement sur la liste Yahoo contre 25% sur les autres. L'analyse des retours n'a rien donné non plus (0 mail en erreur).

Bref, je ne sais plus quoi penser, si je dois réintégrer les Yahoo et réduire le nombre et envoyer par le cron (bien pratique) ou poursuivre ainsi (listes séparées).

Qu'en penses-tu ?

#11 Re : Support général » [Résolu] Pb Yahoo + Cron » 09-12-2017 11:03:22

Salut Arnaud  lol

Je te remercie pour ta réponse aimable et techniquement détaillée car tu as bien saisi que je ne suis pas un programmeur fou. Avec tes explications j'ai pu réaliser tout ce que tu m'as demandé youhou.

Concernant JetMail, je pense avoir saisi la procédure mais j'aimerais que tu puisses me la confirmer :

1. Une fois que j'ai terminé l'envoi de ma liste principale épurée des emails Yahoo, je sélectionne ma liste yahoo

2. Puis je vais dans "Configuration Globale > Gestion des envois" où je modifie les paramètres serveur SMTP / identifiant / mdp avec ceux de mon compte JetMail n'est-ce pas ?

3. Puis je balance la même newsletter aux abonnés Yahoo via ce smtp reconfiguré pour l'occasion de la liste Yahoo (207 abonnés tout de même).

4. Puis je remets les paramètres de mon "hébergement normal" pour la prochaine newsletter, et dans 1 mois, je peux faire un petit test sur 10 mails Yahoo comme demandé n'est-ce pas ?


Si tout cela est exact, j'ai 2 questions qui me viennent du coup :

1. Si j'utilise le smtp d'un autre serveur, cela ne pose-t-il du coup pas de soucis avec les DMARK/DKIM et autres paramétrages internes qui ont été un peu pénibles déjà à mettre en place ?  tongue

2. Sur les 207 Yahoo de ma liste principale, finalement il n'y avait que 20 retours, donc c'est bizarre, normalement si je suis out, n'aurais-je pas du recevoir 207 bouncesmonkey Si oui, peut-être ces 20 retours sont-ils à traiter tout simplement et les autres sembleraient passer ?? (piste de réflexion)

Je te remercie pour le temps que tu accorderas à ta réponse, je dois justement envoyer d'ici 24h ma prochaine newsletter angel

Tout le meilleur pour ta nouvelle version cool

#12 Support général » [Résolu] Pb Yahoo + Cron » 09-12-2017 11:03:22

realdju
Réponses : 8

Salut Arnaud,

J'espère que tu vas bien.

Cela fait longtemps que je n'ai posté ici car j'avoue, la v4 m'a procuré énormément de satisfactions, presque la perfection.

Je reviens vers toi pour 2 choses :

1) Je t'en avais déjà parlé : les tâches cron ne s'effacent pas, tu m'avais parlé d'une maj rapport à cela, où en es-tu ? Disons que je commence à me poser la question car j'ai peur que certaines tâches se relancent 1 an plus tard, cela ferait vraiment tâche du coup mouahah.

2) Depuis la semaine dernière, j'ai une chiée (oui vraiment) de retours Bounce de Yahoo juste affreux alors que jusqu'alors tout allait bien (je précise IP non blacklistée, code propre, suivi des désinscriptions etc). Celà me renvoit ce type de message :

" This is the mail system at host sortant-01.o2switch.net.

I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

                   The mail system

<kody_XXX@yahoo.fr>: host mx-eu.mail.am0.yahoodns.net[188.125.69.79] said:
    554 delivery error: dd Requested mail action aborted -
    mta1145.mail.ir2.yahoo.com (in reply to end of DATA command)



Reporting-MTA: dns; sortant-01.o2switch.net
X-Postfix-Queue-ID: C4D9078E1E7A7
X-Postfix-Sender: rfc822; julien@la-flamme-violette.com
Arrival-Date: Wed, 15 Nov 2017 20:18:33 +0100 (CET)

Final-Recipient: rfc822; kody_XXX@yahoo.fr
Original-Recipient: rfc822;kody_XXX@yahoo.fr
Action: failed
Status: 5.0.0
Remote-MTA: dns; mx-eu.mail.am0.yahoodns.net
Diagnostic-Code: smtp; 554 delivery error: dd Requested mail action aborted -
    mta1145.mail.ir2.yahoo.com "

je crois que dans un de mes messages on avait déjà parlé de Yahoo, et j'avais déjà rempli la fiche de leur truc "WhiteList" qui d'après ton dernier article ne servirait sans doute pas.

J'ai renvoyé une newsletter ce soir : pareil, plein de retours, par ailleurs, je constate que l'envoi est plus long à présent, alors que le nombre d'abonnés n'a pas évolué (envois en cron, par ailleurs top de chez top).

J'espère pouvoir venir à bout de ces 2 points grâce à ta haute expertise tongue

Au plaisir de te lire smile

Julien.

#13 Support général » [Résolu] Cron OK mais pas possible d'effacer les tâches. » 07-06-2017 10:35:27

realdju
Réponses : 1

Coucou Arnaud,

J'espère que tu vas bien, de mon côté je suis toujours ravi de l'envoi de mes news.

Voici 2 points que j'aimerais aborder :

1) Pas très important, c'est quand on enregistre le message, la confirmation en vert est tout en bas de l'écran et du coup on sait pas, ce serait mieux de la placer sur la droite juste en-dessous d'ailleurs de "enregistrer ce message/brouillon" style. Là on doit descendre tout en bas voir si c'est bien le cas, et c'est important pour pas tout recommencer évidemment.

2) L'objet de ce topic, donc mon crôn marche super, je m'embête plus à prendre des risques en envoi direct (coupures internet, fermeture fenêtre malencontreuse etc), pas contre, par exemple, j'ai programmé une tâche dans 1 an sans faire exprès et je clique sur la poubelle mais rien ne se passe, ni sur aucune je crois d'ailleurs. Autre inquiétude : si les tâches sont prévues le 6 Juin, est-ce que chaque année, le 6 juin la même tâche va se ré-exécuter comme une grande toute seule ?

3) Bâh  j'en profite là pendant que j'y suis : une tâche crôn d'envoi est en cours et quand je vais dans les archives, j'ai "284 n'ont pas reçu cette information ! etc" et si j'avais cliqué par erreur (ce que j'ai failli faire, mais j'avoue le cas est rare) je pense que ces 284 personnes auraient reçu la news en double puisque l'envoi était en cours (blond que je suis)... Pendant le crôn, cette archive aurait pu être bloquée. Bon j'avoue un détail... mais l'outil dans l'ensemble est terrible, alors j'espère participer aux peaufinages tongue

A te lire, et belle semaine à toi smile

Julien.

#14 Re : Support général » [Résolu] 1 ères impressions, remarques et questions :P » 09-05-2017 17:42:20

Coucou Arnaud,

Un petit message pour te dire que tout semble résolu à présent, et oui, il s'agissait bien d'un pb de smtp sur une connexion, comme quoi le Cron a de multiples avantages également à ce niveau-là wink

J'ai retrouvé mes 20% manquants, les stats sont au rdv, je gère les retours trankilou bref, l'outil est nickel avec tout ce que tu as amélioré. De mon côté - et c'est personnel et tu l'as déjà bien noté - me manque plus que les archives publiques pour pouvoir partager mes news sur Facebook (auquel cas je mets toujours un petit budget pub de 2e pour me faire connaitre en plus) et ce sera l'outil parfait pour moi youhou tongue

Merci pour tout, tu peux mettre résolu ou je le ferai prochainement.

Bon courage/résussite pour ta nouvelle version, et encore merci pour tout wink

#15 Re : Support général » [Résolu] 1 ères impressions, remarques et questions :P » 09-05-2017 17:42:20

Coucou Arnaud smile

Alors, en allant chercher la fameuse base, je ne comptabilise que 11 emails en erreur "Y" et toujours 1263 abonnés dans la liste, 1.057 envois, donc il reste toujours 206 emails fantômes. Il n'y a plus d'envois en erreur en "jaune".

Par ailleurs, dans "Données chiffrées et graphiques", je lis "1057 envois" pour la dernière campagne mais le fichier "log" indique 1347 lignes avec le status "OK".

Bon j'y comprends plus grand chose : que puis-je te fournir comme données pour aller dans l'enquête ? On attends la v2.0.5 ? Que me proposes-tu ?

Merci Arnaud, à bientôt smile

#16 Re : Support général » [Résolu] 1 ères impressions, remarques et questions :P » 09-05-2017 17:42:20

Hello Arnaud,

Cela fait un certain temps que j'ai posté, et donc je voulais savoir si tu avais une réponse sur les mystérieux 207 méls qui ne sont ni envoyés ni supprimés merci smile

#17 Re : Support général » [Résolu] 1 ères impressions, remarques et questions :P » 09-05-2017 17:42:20

Coucou je pense que tu m'as répondu en focalisant sur l'image avec les retours d'erreur de la V202, sur la v204 il n'y a plus aucun mél en erreur "Bounce" de la sorte c'était simplement pour comparer cette différence notable entre les 2 versions.

Je parlais essentiellement des logs en envoi qui ont compté 237 erreurs à ma 1ère newsletter v2.0.4, suite à ma 2ème newsletter je me demande ce que sont devenus ces 237 méls en erreur :

mini_154146PhpMyNewsLetterAdministrationMozillaFirefox.jpg


>> 1ère Newsletter v204 : 1051 envois + 237 envois en erreurs (environ 1300 abonnés).

>> 2ème Newsletter v204 : 1051 envois + 0 envois en erreur (voir courbe jaune, toujours 1300 abonnés).


Du coup, je ne comprends pas comment sont gérés les fameux 237 méls diagnostiqués à la 1ère newsletter en erreur ?

Ils semblent n'avoir été ni envoyés ni supprimés monkey


Merci pour tes lumières Arnaud, et à te lire smile

Ps : toujours 10/10 pour cette news.

#18 Re : Support général » [Résolu] Plusieurs adresse emails de preview » 28-03-2017 19:57:30

Ok super, cela veut-il dire que les messageries apprécient des configurations spécifiques à leur architecture pour améliorer la déliverabilité ??  monkey

#19 Re : Support général » [Résolu] 1 ères impressions, remarques et questions :P » 09-05-2017 17:42:20

Bonjour Arnaud et merci pour ton assistance,

Ok pour tout, je vais focaliser simplement sur cette histoire de 237 méls en erreur à l'envoi. Bien sûr que c'est important, ça représente 1/5 de ma base !

Alors j'ai comparé les 2 versions encore présentes de phpmynewsletter sur les anciennes et les nouvelles versions donc (202 Vs 204)

Il apparait qu'avec le même paramétrage :


- le log de la 202 ne présente que des envois réussis statut "ok" VS le log de la 204 présente 237 erreurs en envoi du type déjà mentionné " 2017-03-20 18:00:57 ID : 248 0.008  SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/ … leshooting  xxxxxxxxx@orange.fr " et ce, sur différents clients de messagerie.


- l'analyse des retours bounce de la 202 renvoit des lignes (cf ci-dessous) Vs l'analyse de la 204 qui renvoit "aucun erreur en retour"

mini_566921V202bounces.jpg

Ps : dans cette liste, je reconnais des clients avec qui j'échange sans problème par messagerie


- dans tous les cas, mes 1237 méls sont toujours présents et non traités.

Là j'ai l'impression de sortir un lapin du chapeau ou sinon j'ai un pb de paramétrage, pour autant tout semble identique, les listes de retour d'envoi et de d'analyses de retour sont tout de même différentes.


- Lorsqu'enfin je teste qqs adresses apparues en erreur via http://testermail.outils-webmaster.com elles semblent bonnes et je me dis aussi que tu sais il y a 1 mois et demi environ il y a eu un pb avec le soft et certains ont reçu ma newsletter 100 fois dans leur messagerie (la honte ops ) du coup peut-être que depuis ce temps, mon adresse/serveur est blacklisté pour certains de ces utilisateurs ? (manuellement de leur part ou automatiquement par leur messagerie)


Qu'en penses-tu ? Et si c'était le cas, y aurait-il un moment une réapprobation automatique de mes méls (10/10) ou c'est mort ??

Comment puis-je faire des tests ou apporter des éléments concrets ?

Je vais envoyer une autre newsletter là dans pas longtemps j'analyserai de même les données et complèterai ce message smile

Merci Arnaud  angel

#20 Re : Support général » [Résolu] Plusieurs adresse emails de preview » 28-03-2017 19:57:30

Coucou je m'incruste car je suis tellement enthousiaste du soft que je furète le forum lol.

Arnaud, qu'est-ce que tu entends par "ouvrir un canal sur un fournisseur" et quel en est l'intérêt si ton mél a déjà 10/10 sur MailTester ??

Merci smile

#21 Re : Support général » [Résolu] 1 ères impressions, remarques et questions :P » 09-05-2017 17:42:20

Ah que coucou, c'est génial tu sais que trouver le gestionnaire idéal de newsletter m'a pris la tête pendant des mois, et avec ta nouvelle version, pouf, tout s'éclaire, je suis ravi de ces échanges qui me permettront à coup sûr une bien meilleure efficacité et, je le répète, de gros soucis en moins avec le cron (la news est balancée le wé pendant en mode "orteils en éventail" pour de meilleures chiffres en + !)

Bref, merci super je comprends tout ou presque parce que je suis blond, mais à force de répéter ça rentre !

Méls en erreurs envoi

Tu m'as vraiment fait rire : ben oui c'est à l'envoi pas au retour, alors je comprends pas comment ça se peut à l'envoi mais peu importe j'imagine que c'est pas bon pour moi ça, j'obtiens dans la loupe "log" des lignes de ce type :

" 2017-03-20 18:00:57 ID : 248 0.008  SMTP connect() failed. https://github.com/PHPMailer/PHPMailer/ … leshooting  xxxxxxxxx@orange.fr "

Me conseilles-tu de confirmer avec un 2ème envoi un nombre approximatif d'erreurs, puis de les supprimer manuellement ? Je préfère attendre ta confirmation avant de perdre 237 clients potentiels lol  lol

Config de TinyMCE

> Justify : done, cool  cool

> ajout du dico : je me suis rendu ici mais je n'ai pas trouvé le fichier tinymce.init à modifier pour intégrer le plugin spellchecker que j'ai sauvagement mis dans /js/tinymce/plugins est-il possible de le faire ? Ma demande vient du fait que les gens sont super attentifs aux fautes d'orthographe et que je sais en faire dans mes news, donc il y a vraiment une utilité je pense smile

> raccourcis : Top ! (j'avais essayé d'autres raccourcis qui étaient différents, ici, les principaux sont accessibles ce qui évite de faire des aller-retour aux toolbars)

> émoticons : je travaille dans le bien-être donc j'aurais aimé des émoticons de bisounours style yin & yang, fleur etc donc tant pis ça a pas l'air adapté MAIS puis-je remplacer directement les images présentes par mes propres icones "zen" comme j'ai finalement fait pour le background hihi ? smile

Stats.

> La géolocalisation c'est top un bon outil encore, je suis d'accord de ne pas pousser trop trop loin, si déjà on s'occupe des infos actuelles et des erreurs, on améliore énormément.

> Merci pour ces ordres d'idée de stats, n'ayant aucune idée, cela me motive c'est très intéressant merci smile

Mon opinion sur les prochains dévs

> Refonte : moui, bon, pourquoi pas, on a besoin de ça à un moment je sais, je le trouve personnellement hyper accessible et clair, j'espère que tu conserveras ce principe de "simplicité". Laisse-moi deviner, un menu horizontal en haut avec des icones ? Si tu as envie d'avoir des avis extérieurs, tu peux me mettre sur la liste en tout cas je serai heureux de contribuer modestement wink

> Révision du code : je fais pareil en ce moment lol, il parait qu'une info, au départ, est toujours complexe. Plus elle est intégrée et comprise, plus elle se simplifie on est sur la bonne route ! wink

> Dynamique euh bon ok lol.

Cron/Ajax ??

> Veux-tu dire que les news envoyés en ajax sont préférés par les messageries plutôt que le cron ?? ou bien ça ne change rien, pas bien compris  monkey


Merci pour tout Arnaud, d'avance un bon wé, pas pressé pour la réponse, mais ça peut être plus court à présent smile notamment pour


1. La suppression manuelle des erreurs en envoi (ahah).

2. La possibilité du dico pour paraitre moins léger.

3. Remplacement des émoticons à la sauvage

4. La préférence cron/ajax (bon là c'est vraiment optionnel j'avoue je commence à être à court de questions)

Pour le reste tout est ok ou à peu près, raviiiiiiiii.

A te lire,

Julien  angel

#22 Support général » [Résolu] 1 ères impressions, remarques et questions :P » 09-05-2017 17:42:20

realdju
Réponses : 12

Coucou Arnaud,

Je reviens dans le forum suite à l'envoi de ma 1ère newsletter :

1. Bon déjà j'ai noté qu'il me faut plus de temps, comme tu l'as proposé je pense passer à 5 méls/boucle, là ça a fait 15mn environ pour 1400 abonnés, en cron je m'en moque, mais là c'était un envoi direct, donc j'ai ma réponse, je privilégierai le cron lol smile

2. J'ai été assez agréablement surpris de tous ces petits camemberts apparaissant sur les navigateurs etc (par exemple je vois qu'1/3 des personnes consultent via leur phone = adaptation nécessaire de la structure newsletter), et puis les chiffres j'aimais bien avant mais c'est sympa aussi là.

Voici le rendu de ma 1ère newsletter sur la 2.0.4 :

mini_926905PhpMyNewsLetterAdministrationMozillaFirefox.jpg

Il y a des choses que je ne saisis pas, notamment il est indiqué 1,051 envois et 237 erreurs (ce qui fait, oui, les 1288 abonnés à ma news) mais dans "Analyse des retours" j'ai "Pas de mails en erreur" et la liste n'a pas diminuée j'ai toujours le même nombre d'abonnés. As-tu une idée de ces fameuses 237 erreurs ??

3. Peux-tu préciser la différence entre les ouvertures et les lectures ?

4. Niveau rédaction, des choses assez évidentes sont apparues :

   4.1 J'ai rajouté le code dans compose.php depuis un autre post pour retrouver l'alignement. Comment se fait-il qu'il n'y ait la justification parmi les 3 options ??

   4.2 La présence d'un correcteur automatique serait super, comme dans ce forum par exemple; est-ce possible ? Une cliente m'a fait un retour juste pour une groooosse faute que 1280 personnes ont vu lol (je la dis pas j'ai trop honte !).

   4.3 Avant, on pouvait scroller sur le même écran, maintenant ça affiche l'espace de la newsletter en entier, ce qui fait que l'on doit scroller parfois souvent pour aller chercher les codes gras/souligné etc. L'avantage c'est qu'on peut voir à quel point c'est trop long ou non. Pour aller plus vite néanmoins, existerait-il des raccourcis comme dans windows pour le gras ou autre (ctrl + G/T etc) ou pour accéder aux différentes options ?

   4.4 Comment peut-on modifier les émoticons, j'ai trouvé le dossier js/tinymce/plugins/emoticons/img j'ai ajouté un .gif mais il apparait pas faut-il respecter des spécificités ?

5. Toujours 10/10 sur Mail Tester, faudra que je compare avec mes anciennes newsletter sur la 2.0 bon allez purée je suis trop feignant j'y vais, voilà :

mini_265925logs.jpg

Bon alors en comparant avec les chiffres du haut, il y a quand même une différence notable, en moyenne, j'avais 380 ouvertures, et là, seulement 255 mais il est possible que cela change car je l'ai écrite juste hier. Le comptage a-t-il changé ou la méthode est-elle toujours la même ? Je m'attendais à avoir un chouillat plus avec le bon score Mail Tester, ce qui montrerait que déjà avant c'était très bien...

Bon ben voilà c'est un peu long mais nécessaire pour prendre l'outil en main, je me rends compte que la nouvelle version nous invite à mieux examiner et le pb des doublons qui ont disparu ça soulage énormément smile

A te lire, et bonne soirée.

Julien.

ps : j'adore le fait de pouvoir personnaliser l'accueil...

mini_675457accueil.jpg

#23 Re : Support général » [Résolu] centrage texte » 20-03-2017 15:25:00

Trop génial, je me posais la question en rédigeant ma 1ère newsletter : le forum c'est magique !!  cool

#24 Re : Support général » [Résolu] Feedback & Différentes questions :) » 17-03-2017 07:55:10

Bonsoir Arnaud,

Je suis vraiment content que mes remarques t'aient fait plaisir, c'est la moindre des choses vu le travail fourni et puis si on peut améliorer on est gagnants aussi tongue

J'ai pas encore fait de test grandeur nature, mais ce sera prochainement (1 newsletter/sem).

Ok pour tes réponses, je trouve que l'option des urls newsletter est top (là c'est du 100% du coup) et ok pour le reste, du coup je suis vraiment ravi (surtout CRON fonctionnel) et tu peux compter sur moi pour la pub bien entendu wink

**## J'en profite pour faire de la pub pour o2switch, franchement topissime : bonnes perfs illimitées et un prix dérisoire (j'ai même pas de com !). ##**


Si tu le permets, j'ai encore 2 questions qui concernent toutes 2 la page "CONFIGURATION GLOBALE" :

1) Comment fonctionne le "CODE MAIL TESTER" ? Je faisais cela à la main, ici est-ce que cela consiste à toujours renvoyer sur le même url test que l'on peut conserver dans ses bookmarks ? Ou reçoit-on directement par mél le résultat affiché mdr ?? smile

2) Les champs "Nom d'utilisateur SMTP" & "Mot de passe SMTP" restent tout le temps vides même quand on les remets mano mano, pourtant ça envoie en SMTP donc ça ne semble pas poser de soucis, y a-t-il une petite correction à apporter ? J'ai bien pris note dans un autre post que chaque liste comportait ses propres codes, du coup, je me demande ce que font ces paramètres ici ?


Suite à ta réponse, je fermerai ce post et reviendrai dans le forum si je constate encore des bonnes nouvelles ou un bug spécifique (on sait jamais lol).


A bientôt, bravo pour ce travail monstrueux, et encore merci 1.000x angel


Ps : j'espère que tes travaux sont terminés...

#25 Support général » [Résolu] Feedback & Différentes questions :) » 17-03-2017 07:55:10

realdju
Réponses : 3

Bonjour Arnaud,

Je reviens après un long moment et avant de te faire un retour sur mes premières expériences de ta nouvelle version, je pense que le screen suivant te fera plaisir big_smile

Mail Tester

Je précise qu'avec la version 2.0, j'arrivais avec ce même modèle à 8.50/10 cool


Voici donc mon retour sur la nouvelle version :

- Tout d'abord, le + énorme est le CRON qui a fonctionné nickel, ce qui était vraiment un bémol auparavant glasses J'ai paramétré en "dédié" lorsque je suis sous O2SWITCH en mutualisé.

- De loin, ton soft est vraiment bcp plus simple à tous les niveaux que ce qui peut exister de gratuit (oui j'avoue j'ai fait des tests notamment pour trouver une solution cron/url newsletter).

- A la composition d'un message, l'entête <head> avec le style ne disparait plus ce qui rend l'outil très agréable.

- L'envoi semble fonctionner lorsqu'en 2.0 ça freezait et il fallait se rendre dans les archives pour lancer l'envoi.

- Enfin, 10/10 sur Mail Tester, what else ? lol


Nota :

Pour moi, il manque toujours la possibilité d'avoir l'url des newsletters déjà envoyées dans la section "archives" afin de pouvoir les publier sur les réseaux sociaux (au moins que ce soit en option pour ceux qui souhaitent le faire). En parade, j'imagine à l'avenir créer un répertoire "Newsletter" et les mettre directement dedans, mano mano quoi mais bon ça fonctionne. L'autre point noir était le CRON, mais ça... c'était avant lol.


Petits Bugs :

- Dans la composition du message, au départ je trouvais "initialisation en cours", ce dont tu donnes la solution dans un autre post. Je précise avoir fait l'instal en répertoire, et adopté ton 2nd script corrigé.

- Liens brisés dans l'envoi du type NDD/CHEMIN PHPMYNEWSLETTER ce qui donnait style https://www.NDD.com//home/xxx/pmn204/yyy. J'ai résolu en supprimant l'"url de base" dans "réglages divers".


Questions :

1) A quoi sert l'option "Encoder ce mail ?" au niveau de la composition du message ?

2) Penses-tu mettre à terme la possibilité des urls des archives ?

3) Pour 1400 abonnés, me conseilles-tu de conserver les paramètres par défaut du genre "Nombre de messages expédiés à chaque boucle d'envoi : 3" en méthode smtp ?

4) Dans "Configuration de la newsletter", les textarea sont partis en vacances (voir screenshot ci-dessous) ça ressemble bcp à l'absence du corps de message que j'avais à l'install que puis-je faire ?

mini_17031502134340575.jpg

5) Dernièrement, avec la version 2, j'avais des soucis d'envoi multiples et ça a carrément spammé mes propres abonnés, notamment une fois où j'ai perdu la connexion internet, la connexion revenant, je crois que les envois s'étaient accumulés et certains abonnés l'ont reçu une centaine de fois !!! Je précise cela car s'il n'y a pas de sécurité sur les envois ça pourrait recommencer sur la nouvelle version ou as-tu déjà entendu parlé de cela et corrigé cela ?


En tout cas, merci bcp pour ce super outil, en espérant que mon feedback te sera utile ainsi qu'à d'autres.

Julien  smile

Pied de page des forums

Propulsé par FluxBB