PhpMyNewsLetter 2.0

Support et annonces PhpMyNewsLetter.

Vous n'êtes pas identifié(e).

Annonce

Pour me permettre de mieux vous aider au mieux, merci d'être le plus précis possible en donnant :
- la version de phpmynewsletter utilisée
- votre hébergement : personnel, dédié, mutualisé
- votre hébergeur (OVH, free, Infomaniak, 1and1,...)
- votre OS : linux, windows
- version de PHP (5.3, 5.6, 7.0, hhvm...)
Toutes les réponses à mes questions qui sont sans retour de votre part seront considérées comme résolues !

#1 29-10-2018 19:38:47

totorigolo56
Membre

[Résolu] petit bug d'affichage dans la carte de geolocalisation (statistiques)

salut, juste pour chipoter :

dans ma carte du monde j'ai l'impression qu'il y un problème d'affichage des points géolocalisés, car il y a comme une ligne virtuelle à gauche de laquelle on ne trouve aucun point. ce défaut est là peu importe le zoom choisi.

1540838268.jpg

Dernière modification par totorigolo56 (30-10-2018 11:57:30)


V2.0.5 Sur serveur mutualisé chez LWS.
Tout en SSL avec certificat Let's Encrypt.
php 7.2.14 / mysqlnd 5.0.11
Utilisation sous W10 pro. & Firefox 64.0 64bits.

Hors ligne

#2 30-10-2018 10:15:49

Arnaud
Administrateur

Re : [Résolu] petit bug d'affichage dans la carte de geolocalisation (statistiques)

Bon...
Alors déjà un joli score d'ouverture  big_smile  big_smile

Par contre, cette ligne, je dirais plutôt qu'elle marque un vide à gauche.
Est-ce que tu pourrais faire un dump de la structure de la table [prefix]_track stp ? C'est à dire n'afficher que la structure depuis phpmyadmin via une simulation d'export de la table.


Je prends le temps de créer un outil pour tous, de niveau professionnel, mais simple !
Il n'est pas encore parfait, soyez indulgents, ça vient...
Si vous avez des questions, n'hésitez pas ! Mais soyez précis pour une réponse plus rapide  wink

Hors ligne

#3 30-10-2018 11:59:27

totorigolo56
Membre

Re : [Résolu] petit bug d'affichage dans la carte de geolocalisation (statistiques)

oui à gauche ! j'ai rectifié.

heuu, et tu veux le résultat sous forme de capture ou de fichier? je suis pas sur de voir ce que tu veux avec la simulation d'export...


V2.0.5 Sur serveur mutualisé chez LWS.
Tout en SSL avec certificat Let's Encrypt.
php 7.2.14 / mysqlnd 5.0.11
Utilisation sous W10 pro. & Firefox 64.0 64bits.

Hors ligne

#4 30-10-2018 12:21:25

Arnaud
Administrateur

Re : [Résolu] petit bug d'affichage dans la carte de geolocalisation (statistiques)

le fichier, ça doit ressembler à ça :

CREATE TABLE IF NOT EXISTS `pmn2_track` (
`id` int(10) unsigned NOT NULL,
  `hash` varchar(40) NOT NULL DEFAULT '',
  `subject` int(9) NOT NULL,
  `date` datetime NOT NULL,
  `open_count` smallint(3) NOT NULL,
  `ip` varchar(20) NOT NULL,
  `browser` varchar(150) NOT NULL,
  `version` varchar(150) NOT NULL,
  `platform` varchar(255) NOT NULL,
  `useragent` text NOT NULL,
  `devicetype` varchar(10) NOT NULL,
  `lat` decimal(10,8) NOT NULL,
  `lng` decimal(11,8) NOT NULL,
  `city` varchar(255) NOT NULL,
  `postal_code` varchar(255) NOT NULL,
  `region` varchar(255) NOT NULL,
  `country` varchar(255) NOT NULL
) ENGINE=MyISAM AUTO_INCREMENT=129981 DEFAULT CHARSET=utf8;

phpmyadmin > base > table > onglet exporter > export personnalisé, dans sortie cocher "afficher les résultats", dans options spécifiques, cocher "structure" > exécuter en bas de page
et faire un copier coller du résultat avec l'icone de code


Je prends le temps de créer un outil pour tous, de niveau professionnel, mais simple !
Il n'est pas encore parfait, soyez indulgents, ça vient...
Si vous avez des questions, n'hésitez pas ! Mais soyez précis pour une réponse plus rapide  wink

Hors ligne

#5 30-10-2018 18:57:17

totorigolo56
Membre

Re : [Résolu] petit bug d'affichage dans la carte de geolocalisation (statistiques)

Alors voilà :

-- phpMyAdmin SQL Dump
-- version 4.8.3
-- https://www.phpmyadmin.net/
--
-- Hôte : localhost
-- Généré le :  mar. 30 oct. 2018 à 18:55
-- Version du serveur :  10.1.36-MariaDB-1~jessie
-- Version de PHP :  5.6.38-0+deb8u1

SET SQL_MODE = "NO_AUTO_VALUE_ON_ZERO";
SET AUTOCOMMIT = 0;
START TRANSACTION;
SET time_zone = "+00:00";

--
-- Base de données :  `*xxxxmabasexxx*`
--

-- --------------------------------------------------------

--
-- Structure de la table `pmn2_track`
--

CREATE TABLE `pmn2_track` (
  `id` int(10) UNSIGNED NOT NULL,
  `hash` varchar(40) NOT NULL DEFAULT '',
  `subject` int(9) NOT NULL,
  `date` datetime NOT NULL,
  `open_count` smallint(3) NOT NULL,
  `ip` varchar(255) NOT NULL,
  `browser` varchar(150) NOT NULL,
  `version` varchar(150) NOT NULL,
  `platform` varchar(255) NOT NULL,
  `useragent` text NOT NULL,
  `devicetype` varchar(10) NOT NULL,
  `lat` decimal(10,8) NOT NULL,
  `lng` decimal(11,8) UNSIGNED NOT NULL,
  `city` varchar(255) NOT NULL,
  `postal_code` varchar(255) NOT NULL,
  `region` varchar(255) NOT NULL,
  `country` varchar(255) NOT NULL
) ENGINE=MyISAM DEFAULT CHARSET=utf8;

--
-- Index pour les tables déchargées
--

--
-- Index pour la table `pmn2_track`
--
ALTER TABLE `pmn2_track`
  ADD PRIMARY KEY (`id`),
  ADD KEY `hash` (`hash`),
  ADD KEY `subject` (`subject`),
  ADD KEY `date` (`date`),
  ADD KEY `open_count` (`open_count`),
  ADD KEY `ip` (`ip`),
  ADD KEY `browser` (`browser`),
  ADD KEY `version` (`version`),
  ADD KEY `platform` (`platform`),
  ADD KEY `devicetype` (`devicetype`),
  ADD KEY `lat` (`lat`),
  ADD KEY `lng` (`lng`),
  ADD KEY `city` (`city`),
  ADD KEY `postal_code` (`postal_code`),
  ADD KEY `region` (`region`),
  ADD KEY `country` (`country`);

--
-- AUTO_INCREMENT pour les tables déchargées
--

--
-- AUTO_INCREMENT pour la table `pmn2_track`
--
ALTER TABLE `pmn2_track`
  MODIFY `id` int(10) UNSIGNED NOT NULL AUTO_INCREMENT;
COMMIT;

J'ai pas comme toi pour les ligne :
`lat` decimal(10,8) NOT NULL,
`lng` decimal(11,8) NOT NULL,

comme moi la longitude ne va pas dans le négatif à cause du UNSIGNED, du coup toutes les valeurs négatives se retrouvent à 0 (ou sont erronées) , c'est ça?


J'ai réussi à changer comme un grand, en virant l'attribut unsigned, mais le problème persiste...

1540923011.jpg

j'imagine qu'après coup il est impossible de rétablir les valeurs qui sont à 0.0000....  mais que les prochaines entrées seront bonnes

Dernière modification par totorigolo56 (30-10-2018 19:15:25)


V2.0.5 Sur serveur mutualisé chez LWS.
Tout en SSL avec certificat Let's Encrypt.
php 7.2.14 / mysqlnd 5.0.11
Utilisation sous W10 pro. & Firefox 64.0 64bits.

Hors ligne

#6 30-10-2018 19:28:33

Arnaud
Administrateur

Re : [Résolu] petit bug d'affichage dans la carte de geolocalisation (statistiques)

Le problème persiste car les lignes sont chargées à l ouverture des mails
Donc attendre la prochaine campagne
Et tu as compris avant que je ne résolve mais je ne comprends pas pourquoi c était comme ça !!!!
Donc attendre avant de considérer résolu


Je prends le temps de créer un outil pour tous, de niveau professionnel, mais simple !
Il n'est pas encore parfait, soyez indulgents, ça vient...
Si vous avez des questions, n'hésitez pas ! Mais soyez précis pour une réponse plus rapide  wink

Hors ligne

#7 10-11-2018 15:57:58

totorigolo56
Membre

Re : [Résolu] petit bug d'affichage dans la carte de geolocalisation (statistiques)

j'ai refais une autre liste test et ça marche, il y a quelques points qui s'ajoutent au bon endroit ouf, les bretons ne comptent plus pour du beurre !   big_smile


V2.0.5 Sur serveur mutualisé chez LWS.
Tout en SSL avec certificat Let's Encrypt.
php 7.2.14 / mysqlnd 5.0.11
Utilisation sous W10 pro. & Firefox 64.0 64bits.

Hors ligne

#8 10-11-2018 19:25:26

Arnaud
Administrateur

Re : [Résolu] petit bug d'affichage dans la carte de geolocalisation (statistiques)

Merci pour le retour !


Je prends le temps de créer un outil pour tous, de niveau professionnel, mais simple !
Il n'est pas encore parfait, soyez indulgents, ça vient...
Si vous avez des questions, n'hésitez pas ! Mais soyez précis pour une réponse plus rapide  wink

Hors ligne

Pied de page des forums

Propulsé par FluxBB